Multi tracks on GPX

  • Various, the one I am trying to load now is from QMapshack. I tried to load one the other day from Garmin Basecamp and that behaved the same.

  • Gold Members

    I guess multi track is not a “standard” GPX format
    Maybe you should check if there is a way to save a merged version or you can create multiple gpx

  • It works perfectly well on a that other brand starting with G! I generally just cut the GPX at controls or major landmarks. I am having the same issue with a friends Wahoo only recognising the 1st leg on a multi track GPX.

    I really don’t want to save a merged version (I can do that easy enough and normally work in reverse from one GPX and cut it) I actually want the GPX cut into legs. I guess I just need to save a route/track as several separate tracks.

  • Community Manager

    I ll report a use case for this. At the moment most providers as you said wahoo only look at the first trkseg I beleive.

  • Thank you Dimitrios. I’m not sure if most it accurate however, some maybe 😉

  • Should add I have to do this with units like the Garmin 1000 if they are long or it crashes or freezes on anything over around a 100 miles…

  • Moderator

    @Audaxjoe said in Multi tracks on GPX:

    Should add I have to do this with units like the Garmin 1000 if they are long or it crashes or freezes on anything over around a 100 miles…

    I load 100 miles or longer into my S9 and did with Ambit as well as SSU. No issues! Works great!

  • Indeed. I just don’t like looking down and the unit says distance to end is a long way away. Much easier broken into chunks. Just personal preference I guess. Also it is good if say a control is ahead as you know when it is coming. I guess you could also use waypoints for this.

  • Gold Members

    @Audaxjoe I used waypoints in a similar situation when doing a 50 mile race recently. It worked fine and I was getting distance to each next aid station and ETE (estimated time to get there). Although a route with waypoints can be edited only in Movescount.

  • Silver Members

    @Audaxjoe How did you save the GPX file? Have you tried right click and “Save as GPX 1.1 w/o ext…” ? Maybe it can solve this issue. i haven’t give a try for now…

  • Silver Members

    @Audaxjoe You can also merge multiple segments in a single track.
    “ctrl or cmd + click” on each segment you want to combine, then right click and “Combine tracks”.

  • @Audaxjoe said in Multi tracks on GPX:

    Hi when I plan a GPX I am inclined to break it down into legs on one file. When I load this one file with say 4 legs onto SA then sync with my Suunto 9 it only shows leg A. Am I doing something wrong or do I need to save every individual leg into a separate GPX?

    I guess you’re not doing anything wrong since It happens the same for me with an Ambit3 peak. I guess at the moment, Suunto is not able to deal with those GPX files which, by the way, are standard.
    For the reckon, a standard GPX file can hold all in one file multiple tracks (with many legs), routes, and waypoints.

    It might have been some simplified deal since gps watches are small but I plus the fact it should be managed in an other way.

  • @Tim4c yes it isn’t an issue, it would just be easier to save one file with multiple legs then have each leg as a file in its own right.

    @remib I know, all GPS I have had for the last 20 years have coped with legs. I noticed the Wahoo of a friends doesn’t. It isn’t a problem but even loading the track to SA needs to be done x amounts of times instead of once.

Log in to reply

Suunto Terms | Privacy Policy